Wbfs manager-Mountain Lion, the solution (2)

A grande richiesta eccovi una soluzione per aprire il nostro benedetto Wbfs manager 1.2 senza dover andare nel terminale, ossia utilizzando Apple Script (lo trovate in applicazioni-utility), non credo sia l’unica soluzione, ma.. io ho fatto cosi’ e funziona 🙂 Dato che non avevo nessuna voglia di barcamenarmi con il gia’ citato percorso

 /Applications/WBFS\ for\ MacOS\ X.app/Contents/MacOS/WBFS\ for\ MacOS\ X (anche perche non riuscivo a farlo funzionare su apple script 🙂

  1. ho dapprima rinominato il file (contenuto nella cartella Applicazioni) da “Wbfs for MacOS” a “WBFS”  
  2. clic con tasto destro del mouse su Wbfs  ->  scegli “mostra contenuto pacchetto”, apri la cartella “Contents” , apri la successiva cartella “MacOs” e trovi un bel file nero (l’eseguibile) , rinomina anche lui da “Wbfs for MacOS” a “WBFS”  cosi:
    In questo modo il nuovo percorso sara’ /Applications/WBFS.app/Contents/MacOS/WBFS

3.  A questo punto aprite apple script editor (si trova in applicazioni-utility)  e scrivete questo comando:

lo so,potevo scriverlo cosi facevate copia incolla , ma almeno fate un po di pratica 🙂
A questo punto, nel menu apple script selezionate “esporta” e salvatelo come applicazione sulla Scrivania (o dove vi pare),con il nome che vi pare: io l’ho chiamato wbfs.app (che fantasia)
Adesso cliccate l’app creata, vi chiederà la password amministratore, ed il nostro wbfs partirà senza utilizzare il terminale.
Se volete potete applicare allo script l’icona di wbfs cosi non vi accorgerete della differenza 🙂

Questa voce è stata pubblicata in Giochi, Mac Os e contrassegnata con , , . Contrassegna il permalink.

41 risposte a Wbfs manager-Mountain Lion, the solution (2)

  1. marco scrive:

    sei un grande 😉
    guida perfetta funziona alla perfezione

  2. gianni scrive:

    grazie funziona. Ma è normale che per aggiungere un iso stia ore? prima le caricavo in pochi minuti…

  3. Stefania scrive:

    Grazie innanzitutto per la guida… Ma quindi è un problema di Mountain Lion? Ho lo stesso problema con altre applicazioni (Garage Band per dirne una..) che avviandole con sudo funzionano perfettamente…

    • fafa fafa scrive:

      Ciao, grazie, onestamente non dovresti avere alcun problema con le altre applicazioni, specialmente quelle, come GarageBand da te citato, che e’ prodotta dalla stessa Apple. Hai provato a reinstallarlo? oppure a fare un “ripara permessi” in utility disco?

  4. Stefania scrive:

    Ho installato Mountain Lion su un nuovissimo SSD 😉 e quindi da zero, installazione pulita. Ho già eliminato in modo sicuro tutto ciò che faceva riferimento alla precedente installazione di GB. L’ho riscaricata/reinstallata da Mac App Store. Ho già lanciato ripara permessi e verificato i permessi sull’app ma tutto sembra essere corretto… Se lo eseguo come utente amministratore (io) ogni volta mi si avvia il download perché pare non disponga di una installazione completa ( ) ma arrivata alla fine del download tutto ricomincia da capo ;-( se lo eseguo passando dal terminale con il comando sudo tutto funziona regolarmente! Sono un paio di giorni che cerco info a riguardo ma nulla…

  5. Attilio Vicentini scrive:

    Ciao premetto che sono freschissimo a qs problematiche di wbfs e che non ho pratica di Applescript. Ho la necessità di inizializzare un HD in wbfs da un Mac Mountain. Seguite le tue indicazioni, dopo aver immesso la psw incorro nella finestra che mi avverte “/bin/sh: Applications/WBFS.app/Comntents/MacOS/WBFS: No such file or directory”. Cosa si deve fare? Grazie in anticipo

    • fafa fafa scrive:

      Il comando indica che non trova il file nella directory , sembrerebbe che tu non abbia rinominato l’applicazione (come ho scritto nella guida) oppure che tu non l’abbia spostata nella cartella Applications

      • Attilio Vicentini scrive:

        Grazie della solerte risposta! L’applicazione era all’interno di un’altra cartella rinominata con lo stesso nome… ora chiede psw e apre programma, però non vede nessun tipo di discho inserito nelle USB… Anche facendo “Scan for Drive” non vede niente… Cliccando sulla “rotellina” in basso a sinistra lavora per alcuni secondi ma poi rimane la scritta “No Disk Mounted”. Devo far qualcosa prima sulle chiavette per farle riconoscere? Posso formattare con wbsf?

        • fafa fafa scrive:

          Ciao
          Il disco e’ gia stato formattato in wbfs? altrimenti e’ normale che non lo veda.. se e’ vuoto devi formattarlo in wbfs. Poi ti consiglio di scollegarlo e ricollegarlo, non appena viene riconosciuto dal sistema scegli “ignora”, e a quel punto apri wbfs manager, e dovrebbe riconoscerlo

  6. Attilio Vicentini scrive:

    Non uccidermi… come lo formatto wbfs?
    Da utility disco non ho questa opzione…
    Inoltre devo fare solo una partizione?
    Grazie ancora

    • fafa fafa scrive:

      apri Wbfs manager, in alto (vicino alla mela per intenderci), c’e file – edit – Advance, selezioni ADVANCE e sotto c’e la voce : Format connected Drive ; ovviamente prima collega il disco

  7. Attilio Vicentini scrive:

    Trovato solo che è in grigio, non mi permette l’operazione… Ho fatto scan ma non mi trova nessun disco (e ne ho collegati 3!). Getto la spugna?

  8. Attilio Vicentini scrive:

    Niet. Scaricato app, riavviato, controllato se avevo rinominato i due files; parte, psw, programma, ma ancora “format connected drive” in grigio… altra dritta? non ti voglio xò far perdere altro tempo….

    • fafa fafa scrive:

      prova a formattarlo prima in fat32, in utility disco seleziona File System MS-DOS, poi lo estrai, e lo ricolleghi; a quel punto fai partire il programma che (spero) lo riconoscera’ e potrai formattarlo in wbfs

  9. Attilio Vicentini scrive:

    Sarà x un’altra vita…..
    Proverò a sbirciare nel tuo post in futuro…
    Intanto Buon Natale in anticipo e grazie ancora
    A

  10. anto scrive:

    Grazie. Ho trovato istruzioni chiare e anche io ci sono riuscito. Veramente complimenti

  11. ricky scrive:

    Guida perfetta grazie mille.
    Non riesco a capire perché anche a me impiega delle ore a caricare.

  12. ricky scrive:

    Ho provato anche con qwbfsmanager ma ci vogliono sempre tre ore per il caricamento.

    • fafa fafa scrive:

      Ciao, onestamente credo (per esclusione) dipenda dal tipo di supporto utilizzato, prova ad usare un altro disco e verifica se è lento uguale

  13. mancino21 scrive:

    ciao ho seguito la guida e sono riuscito a far partire wbfs ma adesso non mi vede i file su hd come posso fare ???? grazie

  14. Kirirur scrive:

    Grande!!!

    Mi hai salvato! Stavo quando rinunciandomi ad usare WBFS Manager sotto Winblows…

    Grazie!

  15. Elena scrive:

    Grazie, grazie, grazie! Da quanto ho Mountain Lion non avevo ancora re-inserito la mia penna USB e, non vedendola riconosciuta, stavo già dando di matto!
    Mi hai salvato la serata 😛

  16. giuseppe scrive:

    ciao, complimenti anche se la guida e vecchia a me tutt’ora è andata bene, ti volevo chiedere una cosa, quando dall’hd estraggo una iso, la salvo nella cartella download ma poi quando voglio cancellarla per fare spazio ovviamente vado nella cartella e non c’è. poi se faccio add, iso me la vede sai spiegarlo???. grazie

    • fafa fafa scrive:

      Ciao, felice di esserti stato d’aiuto; onestamente non ho mai provato ad estrarre la iso da wbfs (non mi e’ mai servito dato che faccio una copia della iso di metterla su Wbfs) – credo comunque che tu non lo veda per una questione di permessi, immagino che una volta messa su wbfs la iso ottenga i permessi di root – in pratica quando guardi nella cartella tramite WBFS sei l’utente root e quindi vedi la iso che hai estratto, la quale ha appunto i permessi di root; viceversa quando esci da wbfs non la vedi dato che non hai i permessi di root.
      Per poterla eliminare , io proverei da terminale a dare un bel ” sudo rm /Users/TUOUSER/Downloads/FILE.ISO

  17. Linknero scrive:

    ciao non mi legge hd dice che devo riniziarlo
    pero sul wii funziona
    consigli?
    Grazie

    • fafa fafa scrive:

      ciao, e’ normale che su mac non si legga l’hard disk, non reinizializzarlo altrimenti cancelli tutto
      il contenuto del disco lo puoi vedere solo tramite WBFS manager, e devi usare quello per aggiungere le iso al disco

      • Linknero scrive:

        Grazie innanzitutto per la risposta.
        Ti chiedo scusa perché non mi sono spiegato bene
        ho seguito le tue istruzioni “Wbfs manager-Mountain Lion, the solution (2)” purtroppo non riesce a trovarlo
        io ho provato sia prima attaccare HD e poi fare partire WBFS che viceversa
        ma non me lo trova
        Nel senso il Mac mi dice che è da formattare il programma nada.
        Forse con i nuovi mac non va???
        Grazie
        Fabio

        • fafa fafa scrive:

          Ciao, ho provato in questo momento con Maverick (10.9.2) e funziona perfettamente, ho aperto il programma ed in seguito ho collegato il disco e vedo tutte le iso caricate in precedenza; il tuo disco è vuoto? l’hai formattato in wbfs in passato?

  18. Linknero scrive:

    grazie alla tua mail che mi hai mandato ora funziona
    grazie grazie e grazie

  19. Serena scrive:

    Ciao

    ho seguito esattamente il tuo procedimento, mi apre wbfs ma mi dice no disk mounted.

    Non riesco a farlo funzionare!!! Mi puoi aiutare?

    Grazie

    • fafa fafa scrive:

      Ciao, un po di domande prima di poterti aiutare
      -Stai usando la versione 2.1 di wbfs?
      -se inserisci il disco senza aprire WBFS manager il mac lo vede? (dovrebbe chiederti di inizializzarlo)
      -il disco è stato formattato in formato WBFS in precedenza?
      -Prima di aprirsi WBFS ti viene chiesta la password di root ?

  20. ludovica scrive:

    ciao! purtroppo quando avvio script con la stringa mi dice
    La variabile WBFS non è definita.

    che faccio??

    • fafa fafa scrive:

      ciao, se utilizzi la riga di comando e non hai modificato il file WBFS fai cosi (prima pero metti il Wbfs nella cartella applicazioni) :
      apri il terminale
      sudo /Applications/WBFS\ for\ MacOS\ X.app/Contents/MacOS/WBFS\ for\ MacOS\ X , quindi inserisci la password di root e dovrebbe andare

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *